Stop start not working

Faults and Technical chat for the Discovery Sport
Badgerface
Posts: 825
Joined: Fri Jul 28, 2017 5:38 pm
Location: Warwickshire

Re: Stop start not working

Post by Badgerface » Wed Apr 11, 2018 9:58 pm

I think that you'll find that it is classed as a consumable item, rather like a headlight bulb, and excluded from Warranty.

Whilst you and I (and the dealer) all know that this is clearly a faulty battery, they aren't going to replace it unless they are guaranteed a financial kick-back from JLR. Put it another way, if it was your business, what would you do in this situation? Don't necessarily blame the dealer, look at the ridiculous parameters that they have to work to with the manufacturer.
MY17 HSE Luxury TD4 Ingenium 180ps - Aintree Green with Black Pack
MY13 HSE Luxury FL2 2.2 SD4 190ps - Baltic Blue with NO Oil dilution issues whatsoever!
MY12 HSE FL2. 2.2 SD4 190ps - Sumatra Black - Gone


User avatar
Canuk
Posts: 277
Joined: Tue Aug 16, 2016 9:58 pm
Location: Surrey, British Columbia, Canada

Re: Stop start not working

Post by Canuk » Wed Jun 13, 2018 8:08 pm

So I go away on holidays and return to find a flat tire and a dirty car. Fill the tire and wash the car and when I get into the car to check tire pressure the car displays low battery start engine. Start the car and move it into my garage. Next day low battery warning has gone after 1 minute of running.

Drive the car and no start/stop, a few days later pick up grand kids and the start/stop works twice. More than a week since, despite going on a few longer drives, the start/stop does not function. Wife very very happy, but I wonder if it is a sign than something is wrong with the battery or charging.
Blue Disco 2016
2 litre turbo petrol
5 seater


welshdisco
Posts: 88
Joined: Tue Mar 10, 2015 6:17 pm
Location: Cynon Valley, S. Wales

Re: Stop start not working

Post by welshdisco » Wed Jun 13, 2018 8:46 pm

Canuk wrote:
Wed Jun 13, 2018 8:08 pm
So I go away on holidays and return to find a flat tire and a dirty car. Fill the tire and wash the car and when I get into the car to check tire pressure the car displays low battery start engine. Start the car and move it into my garage. Next day low battery warning has gone after 1 minute of running.

Drive the car and no start/stop, a few days later pick up grand kids and the start/stop works twice. More than a week since, despite going on a few longer drives, the start/stop does not function. Wife very very happy, but I wonder if it is a sign than something is wrong with the battery or charging.
Since I complained and told them I was sick and tired of things not working etc. They had my car for two days, the Stop/Start works faultlessly, it has never worked as well ever from new. I wonder if there is a software update that cures it..
HSE Lux, Auto, KAIKOURA STONE, Factory Fit Tow Bar. Service Plan.


User avatar
Canuk
Posts: 277
Joined: Tue Aug 16, 2016 9:58 pm
Location: Surrey, British Columbia, Canada

Re: Stop start not working

Post by Canuk » Thu Jun 14, 2018 4:49 pm

Yesterday once again we go to pick up grand kids from school. Park in front of the school and listen to the radio, naturally it turns it self off after a few moments, restart it and radio runs for a short while before turning off, next time radio runs less than a minute and will not restart by pushing the radio volume /on/off switch.

As I go to push the start button to activate all accessories I see message "low battery start engine" after listening to the radio for 10 minutes???

Kids jump in car as a terrible thunderstorm hits us. Drive off, wipers on full, headlights have turned on , turn on front and rear windshield defrosters (wet kids have misted all the windows) and A/C running as well. 15 minute drive home and park car, shortly after take kids to shopping mall and the yes wait for it,,,,,,,,,,,,,,start/stop works at every stop sign or traffic line up. :evil:

I think that I will buy a good charger for AGM batteries and drain the battery and then recharge it. :ugeek:

Any thoughts??
Blue Disco 2016
2 litre turbo petrol
5 seater


Badgerface
Posts: 825
Joined: Fri Jul 28, 2017 5:38 pm
Location: Warwickshire

Re: Stop start not working

Post by Badgerface » Thu Jun 14, 2018 5:44 pm

You could do a lot worse than invest in a C-Tek MXS5.0 Smart Charger. Best £70 that I have spent in a decade of owning Land Rovers.
MY17 HSE Luxury TD4 Ingenium 180ps - Aintree Green with Black Pack
MY13 HSE Luxury FL2 2.2 SD4 190ps - Baltic Blue with NO Oil dilution issues whatsoever!
MY12 HSE FL2. 2.2 SD4 190ps - Sumatra Black - Gone


Chippy
Posts: 5680
Joined: Sun Mar 15, 2015 7:29 pm
Location: Germany.

Re: Stop start not working

Post by Chippy » Thu Jun 14, 2018 7:01 pm

Correct Badgerface a great charger for caravan and boat owners as well.
Evoque MY18 TD4 SE 180hp. Loire Blue.
DS MY17 (Rejected B pillar ticking). Aintree Green.
DS MY16 (Rejected B pillar ticking). Corris Grey.


Post Reply

Return to “Faults & Technical”