Auto wipers fault

Faults and Technical chat for the Discovery Sport
Post Reply
Malkie
Posts: 8
Joined: Sun May 22, 2016 8:29 pm

Auto wipers fault

Post by Malkie » Wed Jan 15, 2020 3:14 pm

When in auto mode my front wipers seem to be wiping too often. Sensitivity setting has no observable effect. They do stop if no rain, so sensor must be working? Anyone got a fault finding chart or circuit diagram or any ideas!
______________________________________________________________________
2.0 SE Tech Auto in Loire Blue. Privacy Glass and Panoramic Sunroof


nmjeria
Posts: 19
Joined: Wed Mar 13, 2019 9:34 am

Re: Auto wipers fault

Post by nmjeria » Wed Jan 15, 2020 7:56 pm

I also seem to have an issue with the right wiper blade which leaves a smudge in the middle of the windscreen especially when it rains a bit. I have attempted to replace them both with new wiper blades but still have this issue. Maybe others have experienced this and can lend some ideas.
---------------------------------------------------------
My17 indus silver HSE 19" rims 66 plate
hyundai Sante fe premium Plus 64 plate
Ford Mondeo


SarahStreet
Posts: 122
Joined: Sat Apr 13, 2019 9:55 am
Location: Coventry, GB
Been thanked: 21 times
Contact:

Re: Auto wipers fault

Post by SarahStreet » Wed Jan 15, 2020 8:27 pm

Malkie wrote:
Wed Jan 15, 2020 3:14 pm
Anyone got a fault finding chart or circuit diagram or any ideas!
It doesn't quite work like that anymore I'm afraid. Book it in for diagnostics, it can either only be a faulty twist-switch on the wiper stalk or a corrupted piece of software within the BCM. Nothing that a hard CAN reset won't cure.


User avatar
RPR
Posts: 495
Joined: Mon Mar 05, 2018 7:02 pm
Location: Blighty
Has thanked: 16 times
Been thanked: 37 times

Re: Auto wipers fault

Post by RPR » Wed Jan 15, 2020 8:34 pm

nmjeria wrote:
Wed Jan 15, 2020 7:56 pm
I also seem to have an issue with the right wiper blade which leaves a smudge in the middle of the windscreen especially when it rains a bit. I have attempted to replace them both with new wiper blades but still have this issue. Maybe others have experienced this and can lend some ideas.
I get that if I use the screen wash after it does the final sweep
MY18 Indus Silver HSE Black Edition 2.0 TD4 180 ICTP 825w Meridian Audio, Hi Res audio


User avatar
BobbyBox
Posts: 449
Joined: Tue Feb 03, 2015 11:44 pm
Location: South Oxfordshire, UK
Has thanked: 2 times
Been thanked: 10 times

Re: Auto wipers fault

Post by BobbyBox » Wed Jan 15, 2020 10:26 pm

SarahStreet wrote:
Wed Jan 15, 2020 8:27 pm
Malkie wrote:
Wed Jan 15, 2020 3:14 pm
Anyone got a fault finding chart or circuit diagram or any ideas!
It doesn't quite work like that anymore I'm afraid. Book it in for diagnostics, it can either only be a faulty twist-switch on the wiper stalk or a corrupted piece of software within the BCM. Nothing that a hard CAN reset won't cure.
disconnect the battery for a bit? or do I need the diagnostic kit to do that?

Thanks

BB
Discovery Sport 2.0 HSE TD4 (180) MY16, Auto, Loire Blue, Almond Interior, Adaptive Xenons, Roof Rails, Spare Wheel, Mud Flaps, Privacy Glass, Memory Pack, Travall Dog Guard, Removable Tow Bar, Qi Wireless Charging Mat. Built Oct 2015.


User avatar
Canuk
Posts: 372
Joined: Tue Aug 16, 2016 9:58 pm
Location: Surrey, British Columbia, Canada
Has thanked: 6 times
Been thanked: 8 times

Re: Auto wipers fault

Post by Canuk » Sat Jan 18, 2020 1:38 am

I have had that problem in the past with the Disco and other cars, I have always found that a good cleaning around the sensor clears up the problem. Using car washes and hand washing as well, will leave a film on the windshield , or as you may say the windscreen. I have screens on my house to keep out bugs :lol:
Blue Disco 2016
2 litre turbo petrol
5 seater


Post Reply

Return to “Faults & Technical”