CarPlay aftermarket - anyone tried this?

Audio, Navigation, Electronic Faults and Fixes
discomickey
Posts: 7
Joined: Sun Apr 14, 2019 9:45 am

Re: CarPlay aftermarket - anyone tried this?

Post by discomickey » Mon Jul 06, 2020 3:18 pm

OK...so after quite a bit of correspondence with the AliExpress store, I seem to have resolved both of the major issues.

Firstly, the support from the AliExpress store has been truly excellent. Very responsive and helpful. Some messages lost in translation but with a few follow up questions and hand drawn diagrams we got there in the end. If you would like to purchase from them then here is the link to the item (I have absolutley no affliation or relationship with the store but feel that they deserve further sales for the support they provided):

https://a.aliexpress.com/_dTRQWoY

So for the issue with the sound coming in and out. This appears to be an issue for older DSs (2016 and earlier) - you do need to cut (or in my case disconnect two cables from the white connector that goes into the box). See the photo attached. The english translation is not so clear but what you need to do is place the connector as shown with the yellow cable on the left.

Then count 5 pins to the right (where yellow is #1). Then remove the pins on both the top and bottom rows of the connector. I felt it was better to disconnect from the connector rather than cut the cables so that I could reconnect if any issues. I think shrink wrapped the two cables to prevent shorting etc

The second issue was in relation to the rear reverse camera not coming on when putting the DS in reverse. Again this seems to be specific to DSs from 2016 and earlier. It works in the original LR interface but not the CarPlay interface. As previously covered, you do need to connect a wire from the orange reverse camera trigger cable on the aftermarket wiring harness to one of the reversing lights.

I actually took some insipration from another post on the forum which talked about connecting a trickle charger to the towing electrics connector block in the boot.

viewtopic.php?f=8&t=4342&hilit=Ctek+fitting&start=10

Rather than remove all the tailgate trim and connect to a rear reversing light, I attached a cable to the yellow and brown cable on the towing electrics connector block. The biggest pain was routing the cable under the door trims / carpets etc from front to back. Managed it in the end and now the sound and reversing camera is working fine in CarPlay mode.

Thanks to all those that have been before me to help diagnose the issues. If anyone wants further help then please DM me or reply here.

WhatsApp Image 2020-07-01 at 03.04.00.jpeg

Early 2016 Discovery Sport SE Tech Indus Silver

Karper
Posts: 29
Joined: Wed Aug 09, 2017 5:19 pm

Re: CarPlay aftermarket - anyone tried this?

Post by Karper » Thu Jul 09, 2020 11:34 am

Good to hear you got it working, my Disco is from December 2016, so it is luckily a MY17 and it was plug and play (using the advice here on dip switches).

Just a small update on the iOS 14 beta, beta 2 has released and seems to be connecting correctly again. I will need to do more trips to confirm though!

Rockyjr
Posts: 2
Joined: Tue Aug 18, 2020 9:52 pm

Re: CarPlay aftermarket - anyone tried this?

Post by Rockyjr » Tue Aug 18, 2020 10:00 pm

Hi i really need help before a make a mistake, i have an audi a6 c7 2016 with an rmc radio with ami port and my car is manual, i did install an after market camera in my car but my interface is bad quality so i was looking at AliExpress and i wanted to get an apple carplay, android auto with rear camera retofit, but every time i try and ask different companies on AliExpress they say that everything will work except camera, can someone please tell me that some interface will aloud apple carplay with rear camera on an manual gearbox on an rmc radio. Thanks and i will try to post pics of my center console and my rmc model. Thanks

27A76CAC-820B-4DD0-B6AE-61E1FCF84361.jpeg

FBE19EE0-3C36-4C49-BC62-9A250F63ABB6.jpeg


Burnerg81
Posts: 127
Joined: Fri Nov 16, 2018 5:50 pm

Re: CarPlay aftermarket - anyone tried this?

Post by Burnerg81 » Tue Aug 18, 2020 10:19 pm

Have you joined and then posted on a Land Rover forum by mistake?
2015 2.2d HSE auto
Wireless charger
Noble chrome wing mirror covers
Alloy pedals
Aluminium door sills
Aluminium gear shifters
Hard wired dash cam
Hard wired ctek battery charger

Rockyjr
Posts: 2
Joined: Tue Aug 18, 2020 9:52 pm

Re: CarPlay aftermarket - anyone tried this?

Post by Rockyjr » Tue Aug 18, 2020 10:24 pm

Sorry i didn’t realise my mistake but i have a friend with the same problem, the company telling him it will not work. Thanks

ikennethj
Posts: 32
Joined: Fri Jan 31, 2020 5:27 am

Re: CarPlay aftermarket - anyone tried this?

Post by ikennethj » Mon Sep 28, 2020 5:06 am

Hi everyone, hope you all are doing well.

Just thought I gave everyone an update.

So 6 months with the Unique Auto CarPlay system and am still very much in love with it. After our country's Circuit Breaker (Lockdown), I have been using it almost everyday and It does what it says it is supposed to do and is doing it without a hitch for me. With the release of iOS14, there have been no effect on the CarPlay interface. If fact, you can now enjoy a few more backgrounds.

I will still recommend it hands down!

Stay safe

cortezone
Posts: 14
Joined: Sun Oct 06, 2019 5:52 pm

Re: CarPlay aftermarket - anyone tried this?

Post by cortezone » Thu Oct 01, 2020 10:44 am

Hi Discomickey,
Thanks for your post. It's encouraged me to look further at my issue. I bought the same device on Aliexpress but couldn't install it. After removing the head unit (if that's the head unit) i found that the connectors did not correspond. I contacted the seller and he assured me that this was the part I needed (after sending him pics of the head unit and also the main menu of my disco's display).

I'm beginning to think that I need to strip all the way to under the cabby box expose the cables that'll connect to the connectors sent along with the device. Are you able to help with pics you might have taken while fitting yours? I also have a MY2016 but with the Meridian Surround system. I've attached images of the device I got as well as the back of the head unit (or what I thought was the head unit).
Thanks

20200625_171202(1).jpg

20201001_093557.jpg

20201001_093508.jpg


User avatar
BobbyBox
Posts: 509
Joined: Tue Feb 03, 2015 11:44 pm
Location: South Oxfordshire, UK

Re: CarPlay aftermarket - anyone tried this?

Post by BobbyBox » Thu Oct 01, 2020 6:00 pm

You have a different head unit that I've seen before. Most 8" InControl Touch systems (mine included) use Harmann head units with very different connectors. Perhaps this is a Gen 2 in the very first DS's (with the 2.2 engine). The red flag for me is the FoMoCo label with suggests its a Ford head unit.

Others will be along soon with suggestions I'm sure.
BB
Discovery Sport 2.0 HSE TD4 (180) MY16, Auto, Loire Blue, Almond Interior, Adaptive Xenons, Roof Rails, Spare Wheel, Mud Flaps, Privacy Glass, Memory Pack, Travall Dog Guard, Removable Tow Bar, Qi Wireless Charging Mat. Built Oct 2015.

cortezone
Posts: 14
Joined: Sun Oct 06, 2019 5:52 pm

Re: CarPlay aftermarket - anyone tried this?

Post by cortezone » Fri Oct 02, 2020 4:44 pm

Bobby,
I think you're right. It comes with the Meridian Surround system. The seller said this device is compatible with my car but as you can see the head unit hasn't got any sockets that can take the cables that came with the device. I guess I have to look for some dongle device instead. Oh well. JLR should have gotten our backs with some software upgrades that'll introduce CarPlay and Android Auto.

User avatar
BobbyBox
Posts: 509
Joined: Tue Feb 03, 2015 11:44 pm
Location: South Oxfordshire, UK

Re: CarPlay aftermarket - anyone tried this?

Post by BobbyBox » Sat Oct 03, 2020 12:36 am

cortezone wrote:
Fri Oct 02, 2020 4:44 pm
Bobby,
I think you're right. It comes with the Meridian Surround system. The seller said this device is compatible with my car but as you can see the head unit hasn't got any sockets that can take the cables that came with the device. I guess I have to look for some dongle device instead. Oh well. JLR should have gotten our backs with some software upgrades that'll introduce CarPlay and Android Auto.
Aah. Do you have a CD player? If so that will confirm you have the meridian system. I don’t think the CarPlay module is compatible with that. The seller should be able to confirm.
As far as official CarPlay support from LR for these Incontrol touch systems, not a hope I’m afraid. As written on other posts, they have added support only to later generation hardware.
BB
Discovery Sport 2.0 HSE TD4 (180) MY16, Auto, Loire Blue, Almond Interior, Adaptive Xenons, Roof Rails, Spare Wheel, Mud Flaps, Privacy Glass, Memory Pack, Travall Dog Guard, Removable Tow Bar, Qi Wireless Charging Mat. Built Oct 2015.

Post Reply