Radiator fans keep running

Forum for Land Rover Technical Documents & Bulletins
Post Reply
Petedm
Posts: 1
Joined: Wed Mar 27, 2019 2:40 pm

Radiator fans keep running

Post by Petedm » Wed Mar 27, 2019 2:53 pm

Hello new to this forum so apologies if I’m doing things wrong but have a four, now nearly five month old UK spec 240 hp discovery sport Petrol HSE which is exhibiting radiator fan problems. They continue to run whilst engine is running and before engine is anywhere near normal running temperature. Even when this is reached fans still run continuously and only stop when ignition is turned off. Any ideas. It’s been back to the dealership once and couldn’t find a problem but now after the second investigation, with reference to Land Rover technical services, they think the problem has been cured but I’m not convinced and I had actually rejected the vehicle before the second attempted fix. I need evidence from anybody who might have purchased a similar vehicle prior to September 2018 as I intend rejecting the vehicle but need proof that Land Rover were aware of this problem prior to that date. Many Thanks

User avatar
Canuk
Posts: 482
Joined: Tue Aug 16, 2016 9:58 pm
Location: Surrey, British Columbia, Canada

Re: Radiator fans keep running

Post by Canuk » Wed Mar 27, 2019 5:16 pm

My 2016 gas model's fan runs at low speed all the time as did my Merc gas model. Both sped up when the going required it. The temperature stayed much more stable than other cars with a temperature switch with a set turn on .

Not sure about the newer engine but unless it running at top speed I would not worry.
Blue Disco 2016
2 litre turbo petrol
5 seater

Jalees
Posts: 6
Joined: Mon Jul 01, 2019 1:14 am

Re: Radiator fans keep running

Post by Jalees » Wed Jul 03, 2019 8:05 pm

Petedm wrote:
Wed Mar 27, 2019 2:53 pm
Hello new to this forum so apologies if I’m doing things wrong but have a four, now nearly five month old UK spec 240 hp discovery sport Petrol HSE which is exhibiting radiator fan problems. They continue to run whilst engine is running and before engine is anywhere near normal running temperature. Even when this is reached fans still run continuously and only stop when ignition is turned off. Any ideas. It’s been back to the dealership once and couldn’t find a problem but now after the second investigation, with reference to Land Rover technical services, they think the problem has been cured but I’m not convinced and I had actually rejected the vehicle before the second attempted fix. I need evidence from anybody who might have purchased a similar vehicle prior to September 2018 as I intend rejecting the vehicle but need proof that Land Rover were aware of this problem prior to that date. Many Thanks
Hi,

Did you manage to get it fixed ? I am here with same engine same issue but it's an F Pace. I have been reading e pace forum and there also seems to be same issue and I am an F pace owner with same issue fan runs at full speed and it's loud like hovercraft and it keeps on running through out my journey till I switch off the engine.
Trying to gather as much information I can so that I can get a proper solution to this. As on e pace forum people complaining dealer changing coolant pump , and all other related things and problem comes back after some period.

Let us know if you got any resolution for your car.

Thanks.

Regards,
KJ

Jalees
Posts: 6
Joined: Mon Jul 01, 2019 1:14 am

Re: Radiator fans keep running

Post by Jalees » Sun Aug 25, 2019 12:24 am

Petedm wrote:
Wed Mar 27, 2019 2:53 pm
Hello new to this forum so apologies if I’m doing things wrong but have a four, now nearly five month old UK spec 240 hp discovery sport Petrol HSE which is exhibiting radiator fan problems. They continue to run whilst engine is running and before engine is anywhere near normal running temperature. Even when this is reached fans still run continuously and only stop when ignition is turned off. Any ideas. It’s been back to the dealership once and couldn’t find a problem but now after the second investigation, with reference to Land Rover technical services, they think the problem has been cured but I’m not convinced and I had actually rejected the vehicle before the second attempted fix. I need evidence from anybody who might have purchased a similar vehicle prior to September 2018 as I intend rejecting the vehicle but need proof that Land Rover were aware of this problem prior to that date. Many Thanks
Hi,

Thought I should post the solution as I finally got fixed. Its the coolant water pump, which tells to run fan at full speed regardless, error logs shows its water pump, finally dealer replaced it under warranty and it's only few days but I personally checked behaviour after driving fan comes on nicely and stops and comes on again while engine is running. And when it's slightly hot then when you switch off the engine you can hear fan running for a minute or less and it switches off, so it's all now normal. Previously it was running loud and never wants to stop until you switch off the engine. Mine is 25t petrol F Pace 2018-2019

Thanks.

KJ

Q86ARR
Posts: 142
Joined: Fri Jul 21, 2017 9:56 am

Re: Radiator fans keep running

Post by Q86ARR » Sun Aug 25, 2019 11:25 pm

Variable water pump sticking

I know of a few that have been replaced on the petrol Ingenium engines for the same symptoms. Evoque, Disco Sport and E-Pace so far

AdityaB
Posts: 1
Joined: Sun Aug 02, 2020 3:51 pm

Re: Radiator fans keep running

Post by AdityaB » Sun Aug 02, 2020 3:55 pm

Jalees wrote:
Sun Aug 25, 2019 12:24 am
Petedm wrote:
Wed Mar 27, 2019 2:53 pm
Hello new to this forum so apologies if I’m doing things wrong but have a four, now nearly five month old UK spec 240 hp discovery sport Petrol HSE which is exhibiting radiator fan problems. They continue to run whilst engine is running and before engine is anywhere near normal running temperature. Even when this is reached fans still run continuously and only stop when ignition is turned off. Any ideas. It’s been back to the dealership once and couldn’t find a problem but now after the second investigation, with reference to Land Rover technical services, they think the problem has been cured but I’m not convinced and I had actually rejected the vehicle before the second attempted fix. I need evidence from anybody who might have purchased a similar vehicle prior to September 2018 as I intend rejecting the vehicle but need proof that Land Rover were aware of this problem prior to that date. Many Thanks
Hi,

Thought I should post the solution as I finally got fixed. Its the coolant water pump, which tells to run fan at full speed regardless, error logs shows its water pump, finally dealer replaced it under warranty and it's only few days but I personally checked behaviour after driving fan comes on nicely and stops and comes on again while engine is running. And when it's slightly hot then when you switch off the engine you can hear fan running for a minute or less and it switches off, so it's all now normal. Previously it was running loud and never wants to stop until you switch off the engine. Mine is 25t petrol F Pace 2018-2019

Thanks.

KJ
Hi KJ How is your car running now? Any issues after the water pump change? I have the EXACT same issues as you and can choose to reject the car now so I’m wondering if the problem is now behind us with the water pump change or is it still an issue

Q86ARR
Posts: 142
Joined: Fri Jul 21, 2017 9:56 am

Re: Radiator fans keep running

Post by Q86ARR » Sun Aug 02, 2020 4:30 pm

AdityaB wrote:
Sun Aug 02, 2020 3:55 pm
Jalees wrote:
Sun Aug 25, 2019 12:24 am
Petedm wrote:
Wed Mar 27, 2019 2:53 pm
Hello new to this forum so apologies if I’m doing things wrong but have a four, now nearly five month old UK spec 240 hp discovery sport Petrol HSE which is exhibiting radiator fan problems. They continue to run whilst engine is running and before engine is anywhere near normal running temperature. Even when this is reached fans still run continuously and only stop when ignition is turned off. Any ideas. It’s been back to the dealership once and couldn’t find a problem but now after the second investigation, with reference to Land Rover technical services, they think the problem has been cured but I’m not convinced and I had actually rejected the vehicle before the second attempted fix. I need evidence from anybody who might have purchased a similar vehicle prior to September 2018 as I intend rejecting the vehicle but need proof that Land Rover were aware of this problem prior to that date. Many Thanks
Hi,

Thought I should post the solution as I finally got fixed. Its the coolant water pump, which tells to run fan at full speed regardless, error logs shows its water pump, finally dealer replaced it under warranty and it's only few days but I personally checked behaviour after driving fan comes on nicely and stops and comes on again while engine is running. And when it's slightly hot then when you switch off the engine you can hear fan running for a minute or less and it switches off, so it's all now normal. Previously it was running loud and never wants to stop until you switch off the engine. Mine is 25t petrol F Pace 2018-2019

Thanks.

KJ
Hi KJ How is your car running now? Any issues after the water pump change? I have the EXACT same issues as you and can choose to reject the car now so I’m wondering if the problem is now behind us with the water pump change or is it still an issue
The coolant pump isn’t the issue anymore. There is a software update for it now. Most likely an open campaign against your vehicle for the issue

bilo999
Posts: 342
Joined: Mon Oct 19, 2015 6:07 pm
Location: Kent

Re: Radiator fans keep running

Post by bilo999 » Sun Aug 02, 2020 7:27 pm

We had a coolant pump replaced back in March for the same thing - just to note that ours is a 290 and the fans were running full speed and very loud - also literally the day before it was due to go in it popped up a low coolant level warning.

I’m quite sure that there has been bulletin fix for our specific fault as I’m sure a number of 290’s have had the same problem - not sure if it’s the same problem however as described in this thread
DS MY18 2.0 HSE Dynamic 290 - Byron Blue, Side Steps, Entertainment, Adaptive Cruise, LKA, Electric Towbar, Wade Sensing, Magna Ride and every other option!
Gone - DS MY15 2.2 HSE Lux Auto, Adaptive Lighting, Spare Wheel, 20 Black Pack, Side Steps

Viorel
Posts: 6
Joined: Fri Jan 03, 2020 2:35 pm

Re: Radiator fans keep running

Post by Viorel » Wed Nov 18, 2020 12:33 pm

Hello everybody,

Thank you all for your posts! Thanks to you, I found (again...) a solution to my car problem, faster than going to the official LR dealer.

y 2019 DS (240HP, petrol) had shown twice the "Coolant low" warning in 6 months, and indeed the coolant level was just under the MIN (I topped about 200ml each time). Both times it happened after longer (500+km) trips at higher speeds (highway mostly).
The dealer told me "no worries, it's not abnormal", although my Freelander 2 had never needed coolant in 11 years :-) .
I also noticed in one occasion that the fan was too loud, but of course you can't measure the speed of a running fan.

After reading your posts, I went directly and asked to check if there is any s/w update required to my VIN. It was confirmed, and I got what they called " PCM and TCM updates", without replacing the water pump. This was about 3,000km ago, and the coolant level is unchanged.

It seems that indeed some s/w bugs made the entire cooling system (pump, fan, coolant) perform poorly. I hope the fix is permanent :-)

Good luck to all and keep posting useful info,
Viorel (Bucharest)

Post Reply