Radiator fans keep running

Forum for Land Rover Technical Documents & Bulletins
Post Reply
Petedm
Posts: 1
Joined: Wed Mar 27, 2019 2:40 pm

Radiator fans keep running

Post by Petedm » Wed Mar 27, 2019 2:53 pm

Hello new to this forum so apologies if I’m doing things wrong but have a four, now nearly five month old UK spec 240 hp discovery sport Petrol HSE which is exhibiting radiator fan problems. They continue to run whilst engine is running and before engine is anywhere near normal running temperature. Even when this is reached fans still run continuously and only stop when ignition is turned off. Any ideas. It’s been back to the dealership once and couldn’t find a problem but now after the second investigation, with reference to Land Rover technical services, they think the problem has been cured but I’m not convinced and I had actually rejected the vehicle before the second attempted fix. I need evidence from anybody who might have purchased a similar vehicle prior to September 2018 as I intend rejecting the vehicle but need proof that Land Rover were aware of this problem prior to that date. Many Thanks


User avatar
Canuk
Posts: 349
Joined: Tue Aug 16, 2016 9:58 pm
Location: Surrey, British Columbia, Canada
Has thanked: 5 times
Been thanked: 4 times

Re: Radiator fans keep running

Post by Canuk » Wed Mar 27, 2019 5:16 pm

My 2016 gas model's fan runs at low speed all the time as did my Merc gas model. Both sped up when the going required it. The temperature stayed much more stable than other cars with a temperature switch with a set turn on .

Not sure about the newer engine but unless it running at top speed I would not worry.
Blue Disco 2016
2 litre turbo petrol
5 seater


Jalees
Posts: 2
Joined: Mon Jul 01, 2019 1:14 am

Re: Radiator fans keep running

Post by Jalees » Wed Jul 03, 2019 8:05 pm

Petedm wrote:
Wed Mar 27, 2019 2:53 pm
Hello new to this forum so apologies if I’m doing things wrong but have a four, now nearly five month old UK spec 240 hp discovery sport Petrol HSE which is exhibiting radiator fan problems. They continue to run whilst engine is running and before engine is anywhere near normal running temperature. Even when this is reached fans still run continuously and only stop when ignition is turned off. Any ideas. It’s been back to the dealership once and couldn’t find a problem but now after the second investigation, with reference to Land Rover technical services, they think the problem has been cured but I’m not convinced and I had actually rejected the vehicle before the second attempted fix. I need evidence from anybody who might have purchased a similar vehicle prior to September 2018 as I intend rejecting the vehicle but need proof that Land Rover were aware of this problem prior to that date. Many Thanks
Hi,

Did you manage to get it fixed ? I am here with same engine same issue but it's an F Pace. I have been reading e pace forum and there also seems to be same issue and I am an F pace owner with same issue fan runs at full speed and it's loud like hovercraft and it keeps on running through out my journey till I switch off the engine.
Trying to gather as much information I can so that I can get a proper solution to this. As on e pace forum people complaining dealer changing coolant pump , and all other related things and problem comes back after some period.

Let us know if you got any resolution for your car.

Thanks.

Regards,
KJ


Post Reply

Return to “Technical Documents & Bulletins”