Page 21 of 27

Re: Outside temperature sensor issues.

Posted: Mon Oct 30, 2017 10:24 am
by Bugginbob
Have had this happen a few times before - temp gauge showing -16 (when about 20 degrees outside) then quickly climbing back up to +20. Today though was the first cold morning since i've owned the car. Started up, temp gauge read 2 degrees, drove 3 miles to get some fuel, started the car back up and read -16. 18 miles later it had crept up to -2. it definitely wasn't that cold.

Will add it to the snagging list for first trip back to the dealer (if they ever reply to my emails that is)

Re: Outside temperature sensor issues.

Posted: Wed Nov 01, 2017 7:34 pm
by Gilfishman
Yet again back in for more problems inc this one,,,re booked in 21 November to have a new part fitted to put this right....

Re: Outside temperature sensor issues.

Posted: Wed Nov 01, 2017 7:52 pm
by Chippy
Perhaps they meant it would be available in July 2018 and not 2017 :o

Re: Outside temperature sensor issues.

Posted: Wed Nov 01, 2017 9:01 pm
by Loopylumpy
Never had it happen in my 2 years with our MY16 HSE. Its happened several times with my month old 2018 HSE.

Another "endearing" Land Rover feature.

Re: Outside temperature sensor issues.

Posted: Fri Nov 03, 2017 1:22 pm
by Robbie.H
Mine is booked in for the described software update next week; double checked it’s available with dealer today.

I hope it works and doesn’t make things worse.. (nervous)!

Will let folks know here..

Re: Outside temperature sensor issues.

Posted: Thu Nov 09, 2017 9:16 am
by roadster
Had my first experience of this yesterday. I was on a longish journey and made a brief first stop after about 90 miles. When I restarted I was surprised to see the ice warning alert at 3 degrees C. The outside temperature was well over 10 and it was sunny and dry. It fairly soon started to go up but I have no idea whether the readings are accurate now.

Re: Outside temperature sensor issues.

Posted: Thu Nov 09, 2017 9:21 am
by Andyrep
New fix doesn’t work !!

Re: Outside temperature sensor issues.

Posted: Thu Nov 09, 2017 9:44 am
by Chippy
Q. When is a fix not a fix?
A. When it's a LR fix.

Re: Outside temperature sensor issues.

Posted: Thu Nov 09, 2017 10:37 am
by BFGDSMan
Maybe you should sprinkle this over the dashboard - - apparantly its a tasty fix

:lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol: :lol:

Maggi Fix.jpg


Re: Outside temperature sensor issues.

Posted: Thu Nov 09, 2017 9:42 pm
by Robbie.H
Had the software fix done today, so far so good.

Obviously, only time will tell if it’s a cure...