Discovery Sport Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi,

Sat Nav/voice search on my 2015 Discovery Sport SE Tech has recently stopped working 'no Navigation data available,please install SD card. To activate navigation please restart engine'

Also interior lights wont come on upon entry but work fine when turned on and will go off when car is locked?

Anyone have an easy fix to either of these problems?

What is up with these Cars are they really that unreliable i only bought it in Oct and most of the electrics went within a week.

Thanks in Advance.
 

·
Registered
Joined
·
25 Posts
You've probably already tried it, but try re-inserting the SD card - I got that message today, just after the wife bunged a load of stuff in the armrest storage. Turns out she'd clicked the SD card out of its holder.
 

·
Registered
Joined
·
134 Posts
lfctv1 said:
Also interior lights wont come on upon entry but work fine when turned on and will go off when car is locked?
In terms of the light try touch and holding your finger in the centre of the light cluster in the roof to turn it back on when the doors open. You should get a message on the dash to let you know it's back on. It took me ages to work out how to turn them off!
 

·
Registered
Joined
·
428 Posts
lfctv1 said:
Hi,

Sat Nav/voice search on my 2015 Discovery Sport SE Tech has recently stopped working 'no Navigation data available,please install SD card. To activate navigation please restart engine'

Also interior lights wont come on upon entry but work fine when turned on and will go off when car is locked?

Anyone have an easy fix to either of these problems?

What is up with these Cars are they really that unreliable i only bought it in Oct and most of the electrics went within a week.

Thanks in Advance.
Good morning lfctv1,

Thank you for your post.

I would like to investigate your concerns further. Please may I request that you send me your VIN and contact details via PM, and I would be happy to help.

Many Thanks,

Dan - Land Rover UK
 

·
Registered
Joined
·
84 Posts
Valisk said:
You've probably already tried it, but try re-inserting the SD card - I got that message today, just after the wife bunged a load of stuff in the armrest storage. Turns out she'd clicked the SD card out of its holder.
I had a similar issue a few weks ago, kept telling me insert sdcard or no sd card found. After many attemps and system resets it finally sprang back into action.
Same issue my wife was fiddling with cables nera the sd card and her fingers accidentally ejected the sd card.
 

·
Registered
Joined
·
389 Posts
Had similar issues with a house security camera, where the card reader stopped working for no apparent reason.
Got a can of compressed air and blasted it into the card slot to blow out any dust or muck that may have got in there.
Popped the card back in and all was well.
 

·
Registered
Joined
·
1 Posts
I have used the previous ways to get SatNav working, but after the hot day this month the SatNav would not work, DAB radio would not store and at times would not play through speakers. Contacted main dealer, state £212/hr to fix, once they found out what the problem was. But to their credit suggested using the update map software. Did this, still no luck, did not recognise card. So I thought I would have to go to main dealer or other specialist or get a third party SatNav which would have been cheaper. So I thought I would try one last cure, to delete all personal data, turned engine off and on again, like magic all be to normal. Have had to pair phone back and have lost a few stored locations, but that is no harm. So I will try update and delete data next time, because it does happen on pre 2016 versions a lot.
 

·
Registered
Joined
·
1,104 Posts
I have used the previous ways to get SatNav working, but after the hot day this month the SatNav would not work, DAB radio would not store and at times would not play through speakers. Contacted main dealer, state £212/hr to fix, once they found out what the problem was. But to their credit suggested using the update map software. Did this, still no luck, did not recognise card. So I thought I would have to go to main dealer or other specialist or get a third party SatNav which would have been cheaper. So I thought I would try one last cure, to delete all personal data, turned engine off and on again, like magic all be to normal. Have had to pair phone back and have lost a few stored locations, but that is no harm. So I will try update and delete data next time, because it does happen on pre 2016 versions a lot.
Worth backing up your SD card and copying the contents to a faster SD card.
 
  • Like
Reactions: Canuk

·
Registered
Discovery Sport Landmark edition 2019
Joined
·
25 Posts
I've had the same issue and cloned the LR card to new (faster) card and all was well the LR card only works intermittently when I try it but the cloned card works 100%
 
1 - 13 of 13 Posts
Top