Discovery Sport Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Hi All,
Loving the new car but having a problem with the radio not retaining the presets. These seem to store OK but next time I'm in the car, the stations I chose have gone and some sort of 'default' presets have replaced them. Anyone got any ideas or is it a trip to the dealer?
By the way I think the standard system on the HSE sounds really good.
Thanks.
 

·
Registered
Joined
·
677 Posts
So far all my presets seem to be OK. Perhaps a trip to the dealer.

Stupid question but you do press the screen for a few seconds to store? I'm can't remember if it makes a bleep or goes quite for a second.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
Just tried again this afternoon and seems to be OK now :? Gremlins - or Operator Error :oops:
 

·
Registered
Joined
·
55 Posts
bobd
We have had exactly the same problem, you set the stations and then it defaults back, at some time later to BBC stations that were set when we purchased the strange thing is the name is slight different on the BBC to that which is being broadcast. However the radio has currently retained for a week, so fingers crossed, the dealer has said bring it in but it is only one of a number of quirks of the system.
 

·
Registered
Joined
·
46 Posts
I can't seem to retain Capital as I travel - the neaterLondon I get the worse the coverage seems to be - has anyone else experienced this?
 

·
Registered
Joined
·
100 Posts
bobd said:
Hi All,
Loving the new car but having a problem with the radio not retaining the presets. These seem to store OK but next time I'm in the car, the stations I chose have gone and some sort of 'default' presets have replaced them. Anyone got any ideas or is it a trip to the dealer?
By the way I think the standard system on the HSE sounds really good.
Thanks.
Im just finding this now. Enter the pre-sets, it retains them for the journey, then defaults to a seemingly random set next time the car's started. Anyone found a fix, or am I screwing up somewhere?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #7 ·
As far as I am aware, I didn't change anything or do anything different. It just started saving the presets as I wanted them and has been OK since. :?
 

·
Registered
Joined
·
506 Posts
Mine did exactly the same, reverting to BBC DAB after a few days.

Reset them last week and so far so good. Being an oldie, I even ditched R1 in favour of Classic on the BBC DAB, and it retained my setting, even though it's not a BBC station.

Will see how it pans out overtime!
 
G

·
I believe it only happens on the DAB radio and then only if you switch on in a different location as it then needs to re-tune. This happened to me but the FM presets seem to be retained.

I think this may be so as in my caravan we have to re-tune our (digital of course) TV whenever we arrive at a new location. Might be worth entering some presets at home and trying them next day, also at home - I'd almost bet they will still be there. If they are lost when somewhere else then that will be it.

If I'm right it makes a DAB radio in a car about as useful as t**s on a bull and I won't bother using it :?
 
1 - 9 of 9 Posts
Top