Discovery Sport Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Driving me nuts and I can't find out why, every time I start the car the radio comes on, doesn't matter if I've had it on or off previously, it always comes on when I start the engine. :evil:

Could some kind soul tell me how to stop it please?
 

·
Registered
Joined
·
4,159 Posts
There are other posts on the forum regarding this and quite a few people have this issue. I have just checked and if turned off my radio is off on re-entering car so it is obviously a fault and not meant to happen.
 

·
Registered
Joined
·
39 Posts
Been doing some testing...!

I believe this is related to auto start/stop.

I turned off auto SS, turned off the radio, parked, turned off the engine the old fashioned way then restarted - the radio stayed off.

With auto SS on I turn the radio off pull up, stop with the foot brake, auto SS kicks in engine goes off, about 5 seconds later the radio comes on again but goes off once I open the door to exit. When I restart the engine the radio comes on automatically.

No idea if this is a fault or a feature but I'm sure that's the answer as I can replicate it 10 times out of 10 - can anyone else test and confirm?
 

·
Registered
Joined
·
397 Posts
Had a demonstrator out on Saturday for a couple of hours and it did this too. Very annoying. There must be a way to turn it off but no handbook with the car.
 

·
Registered
Joined
·
166 Posts
MikeLondon70 said:
Been doing some testing...!

I believe this is related to auto start/stop.

I turned off auto SS, turned off the radio, parked, turned off the engine the old fashioned way then restarted - the radio stayed off.

With auto SS on I turn the radio off pull up, stop with the foot brake, auto SS kicks in engine goes off, about 5 seconds later the radio comes on again but goes off once I open the door to exit. When I restart the engine the radio comes on automatically.

No idea if this is a fault or a feature but I'm sure that's the answer as I can replicate it 10 times out of 10 - can anyone else test and confirm?
Tried that, but got back in and started and the radio was on... Hmm.
 

·
Registered
Joined
·
39 Posts
I tried it literally straight away, this morning when I got in the car it was doing it again - so I guess back to the drawing board - maybe it will be sorted in a future software update
 

·
Registered
Joined
·
230 Posts
there are loads of settings, it must be a tick box option how it operates on engine start?
 

·
Registered
Joined
·
829 Posts
I will get the options that the dealer can set by Tuesday, hope this is one of the items that dealers can programme
 

·
Registered
Joined
·
166 Posts
My dealer said it happens.. others at dealerhip who drive them have noticed.. they weren't aware of the fix..
I thought mine was sorted earlier, but noticed it was no reception on DAB..
 

·
Registered
Joined
·
230 Posts
I have found we loose DAB reception, we live in Kent on the outskirts of London, so this should not really be a problem in terms of reception?
 
1 - 16 of 16 Posts
Top