Discovery Sport Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Wanted to post here as I when my P300e started playing up I researched on forums to find a number of people have been having issues which I found useful to know so wanted to post my experience in case it helps others!

I own a P300e (70 plate one of the first releases) which I took ownership of in November last year. Around 4 months of owning car it threw up a number of error messages relating to stability control not available, Hill descent, forward assist not available etc and no EV regen or electric despite battery being fully charged. Upon powering vehicle down the errors cleared and EV came back Spoke to Land Rover who said if the errors cleared nothing they can do. Didn’t happen again for a few months.

When it happened again although it cleared on power down the issue reappeared 3 times in the same week. Called our Land Rover Assist they did software updates which seemed to fix issue

3 weeks later issue reoccurred but this time took longer to clear and when it did clear kept reappearing. Land Rover Assist came out again said fault code was showing ABS software issue so updated a further 2 modules.

Further point to note is that at first the error only occurred when starting vehicle and driving off the drive. As time went on it would come on randomly when driving as well.

Car was running like a dream after best it’s ever ran. Went into service all fine. Got into car to go on holiday and issue reoccurred on journey down. Once we arrived called out Land Rover Assist who came out said there were loads of faults showing around Tourqe calculation, processer performance. Powertrain module, demand sensors. And he suspected a fault with the Electric power converter module. Said vehicle was safe to drive and should book it in at local dealership when we got back from holiday and that we should continue to power down to clear the error when it occurred.

This was the Monday.. by the Wednesday the error wouldn’t even clear with power down so rest of holiday was spent getting at best 23 MPG through Cornwalls country lanes.

On Monday I dropped car at Land Rover where it has been ever since. They have 2 other P300e in with the exact same issue. They are still testing...no idea what is wrong. Waiting on LR Technical Assist Team to come back to them. Been basically told not to expect my car back anytime soon! No courtesy cars available! Which has left me up the creek without a paddle so to speak!!
So now have to wait and see what happens!
 

·
Registered
Joined
·
202 Posts
trouble is a diesel is no longer simple and straight forward, dpf egr, common rail, all complicated added kit
 

·
Registered
Joined
·
68 Posts
Still a damn sight easier to repair from a mechanical perspective than ANY PHEV/BEV, that’s for sure! Their components are designed to be thrown away and replaced (at vast expense). So much for the “green” revolution. You stick to yours, and I’ll stick to mine.

Remember….Greta loves you!!
(until she decides that BEV’s are no longer carbon neutral and you must give them up as well)
 

·
Registered
Discovery sport P300e SE
Joined
·
1 Posts
Hi all,

I do not usually register to forums, but this thread is too close from my own experience not to register :).

Got similar issues (EV not working anymore, Traction control inactive, "Check your engine" light on) multiple times on a similar car (also got it last November, after the turbo of my previous one (TD4 180) died taking the full engine with him...) : my car was 4 months total in reparation, but by package of 3 to 5 weeks, each one separated by some hours (usually the car stayed the evening in my house before returning to the dealer...).
They changed:
  • the power converter
  • the electrical engine
  • something else related to the EV part
And finally gave up and ask for LR expertise. Which came (flying docs) and where it was decided to change the full battery pack.
This solved all of my issues.

For the courtesy car... No idea how it goes in the UK (I am located in France), but if the dealer has no car, LR's assistance should have rent you one. It was done for me (drove a lot of cars during those 4 months (Q5, Disco Sport, Disco, Lexus NX250h, DS7). So it might make sense to call them and explain your problems...

Christian
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #6 ·
Thanks for replying. I received my car back today after 8 days. All they have done is took the electric motor out and greased and lubricated all the bearings and put it back in and said that should fix the issue!
On the drive home from the garage EV didn’t engage at all. So the issue hasn’t been solved! Although I admit the error messages aren’t coming up so in there mind they have sorted it I guess! Have called the Dealer back to say it’s not fixed but they are not speaking to me “the person I need to speak to will call me back as they are with someone or on the phone” but they haven’t (convenient)!
 

·
Registered
Joined
·
10 Posts
Thanks for replying. I received my car back today after 8 days. All they have done is took the electric motor out and greased and lubricated all the bearings and put it back in and said that should fix the issue!
On the drive home from the garage EV didn’t engage at all. So the issue hasn’t been solved! Although I admit the error messages aren’t coming up so in there mind they have sorted it I guess! Have called the Dealer back to say it’s not fixed but they are not speaking to me “the person I need to speak to will call me back as they are with someone or on the phone” but they haven’t (convenient)!
Hi, there is another chat thread on this site “EV temporarily not available” There are loads of posts on there including my own experience. Mine doesn’t seem as complex as yours however after 3 weeks in the dealership workshop it seems to have been sorted. The issue with mine and many others is a faulty high voltage coolant heater. This is something to do with keeping the EV battery stable and if faulty the EV mode won’t work. Perhaps have a look at that chat thread and email some of the info to your dealership…it worked for me 🤞🏻.
 
1 - 7 of 7 Posts
Top