Discovery Sport Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Can I ask for solutions to my problem.....?

I know Disco Sport have their issues but I have not been able to resolve my lack of Bluetooth, Radio detuned and lost intermittent DAB, cannot store radio stations and sat nav postcode button not working.

Local dealer worse than a useless and local indy specialist also cannot help.

Is happening to a few cars of similar age I see....not acceptable surely?
 

·
Registered
Joined
·
606 Posts
Can you confirm which version of the infotainment system you have (8inch with physical buttons or 10inch)?

You can try removing, cleaning and reinsert the SD card.
While you are at it you can speed up the SavNav with a class 10 SD card. I use a Mac so used Disk Utility to take a complete image (clone) of the SD card and then restored it to a new class 10 SD card. The main speed improvement I see is loading, inputing postcodes and then calculating the route. I also like to have a backup!

Failing that, sounds like you need a complete re-install of the infotainment system software. This is a dealer fix.

If it is the 8inch InControl Touch system then the latest (and final version) is 3.6 (JLR_3.6R01_01_LVLV_SW09_Aug_2019) released in Aug 2019.

Jacinto Version: JLR_3.6R01_01_LVLV_SW09_Aug_2019
Ipl Version: 15.0
Speech Version: 2016.W15R01_NATP-16212A
V850 App Version: 25.96
V850 Boot Version: 12.0
KPIT Boot Version: KPIT_REBESAS-J1.00.11.03
DAB Firmware: 12.0.10
SatNav Software: 9.12.38.669223 (this is NOT the maps data)
GPS Firmware: 3_1_18_UPG
Bluetooth Avrcp: 1.6

To find your InControl Touch version:

1. Turn on FM RADIO and turn volume up to at least 1.
2. Press and hold SOURCE for 8-10 seconds.

You are looking for Jacinto Version and then compare it to the list above.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thank you for that info, I have cleaned the SD card but sadly not helped. Good to know I can speed up the slow satnav also.

JLR want me to pay £180 for a diagnostics appointment (even though my specialist said they have done this at no cost and there is no fault).

I agree a reinstall is probably the only solution, finding someone to do it seems impossible at the moment!.
 

·
Registered
Joined
·
3,909 Posts
Have you done a system reset in the Settings menu? Usually brings back vanished DAB.
 

·
Registered
Joined
·
3,909 Posts
Bowerbird said:
Thank you for the suggestion, I don't have that option in settings.
You do, if you have ICT - from memory maybe it's not called that, but reset, or clear settings, or something less clear. Tried a search on here for some exact description or photos but couldn't find any - but loads of times when it's worked.
 

·
Registered
Joined
·
606 Posts
At the main home screen, press the bottom right gears.
Select "System"
At the bottom select "Delete all personal data"
Press "Yes"
 

·
Registered
Joined
·
3,909 Posts
sandbox said:
At the main home screen, press the bottom right gears.
Select "System"
At the bottom select "Delete all personal data"
Press "Yes"
Thanks!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Thank you - I do have delete all personal settings, will give it a go.

More extreme method but has anyone found taking the red battery clip off for 30mins to reset?
 

·
Registered
Joined
·
606 Posts
Bowerbird said:
Thank you - I do have delete all personal settings, will give it a go.

More extreme method but has anyone found taking the red battery clip off for 30mins to reset?
That is certainly the nuclear option! Although, in reality that won't delete any of the settings held and double locking the car and leaving it for 30mins does much the same thing.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #11 ·
Deleting personal data has worked, checked software version Dec 20.

Off for a drive soon so will see how it performs!

My brother is a Mechanical Engineer (ex JLR) so he thought of the battery as a last resort, might still need it!.
 

·
Registered
Joined
·
606 Posts
Bowerbird said:
Deleting personal data has worked, checked software version Dec 20.
Just so you know the "Dec 20" isn't 2020 but 2015! The last 2 digits are truncated and aren't shown.

When you check the version you need to look at the beginning of the Jacinto Version and the latest is 3.6 ( JLR_3.6R01_01_LVLV_SW09_Aug_2019):

2.5 = JLR_2.5R09_05_LVLC_SW_11_Dec_2015
3.0 = JLR_3R05_09_LVLC_SW_28_Jul_2016
3.1
3.2 = JLR_3.2R01_03_LVLC_SW_17_Feb_2017
3.3 = JLR_3.3R01_01_LVLC_SW_25_MAY_2017
3.4 = JLR_3.4R01_04_LVLC_SW_31_Oct_2017
3.5
3.6 = JLR_3.6R01_01_LVLV_SW09_Aug_2019
 

·
Registered
Joined
·
1 Posts
Hello all,

I don't know where/how to look for this. A colleague of mine has a Range Rover Evoque 2018 and wanted to ask if it is possible to update the software of the car or is there any newer versions etc...? If so, do you know what is the latest version and how to update it?

Current version:
Jacinto Version: JLR_3.4R01_04_LVLC_SW_31_Oct_201..
Ipl version 15.0

Thanks in advance for any support.


Best regards.
 

·
Registered
Joined
·
765 Posts
Might be an idea to ask on the Evoque forum:unsure:
 
1 - 14 of 14 Posts
Top