Discovery Sport Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter · #1 ·
So after many many months of waiting I was finally booked in to collect my DS this afternoon but unfortunately it was not meant to be.

SO the story goes:
After fitting the tow pack, the vehicle started displaying text on the main display in Dutch, when in reverse only. All other language was in English and resetting to English apparently didn't help. Weird but clearly a software problem. JLR recommended a software update, which was duly applied by the dealer which has:
a) not fixed the Dutch text
b) broken park assist sensors altogether
:(
So now the car's stuck in the dealer until JLR can provide a software fix that works properly. The dealer is hopeful this will be by Monday, but given the bizarre nature of the problem and the fact this is an Australian model (ie different towbar / electrics / etc) I'm not quite as optimistic. Seems highly likely related to the tow pack but AFAIK I'm the first person in country to have one fitted!

Anyway here's hoping it's sorted soon and to their credit the dealer has been very accommodating so far about the inconvenience. Will update when I have more answers :)
 

·
Registered
Joined
·
829 Posts
Very sad and how rare!
If you need a translation to English I can help and since my wife came over from Sydney we could even provide some local tones
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #3 ·
KaikouraDiscoSport said:
Very sad and how rare!
If you need a translation to English I can help and since my wife came over from Sydney we could even provide some local tones
Haha yes if it was just the language it wouldn't be so bad, but it seems to have shut down all the parking sensors altogether now :(. Hoping for some good news today.
 

·
Registered
Joined
·
118 Posts
"Software Update"
Seems to be the LR catch all equivalent of the IT world's "try turning it off and back on again"
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #5 ·
srdsol said:
"Software Update"
Seems to be the LR catch all equivalent of the IT world's "try turning it off and back on again"
On Topix there's now a bulletin related to "detachable towbar harness foul". I have no idea what's in it (no subscription) but the dealer tells me there's a bulletin so I'm guessing it's that one. No fix and no ETA from JLR :(. Based on the behaviour of the system I observed, I suspect the wiring hardness may be the wrong spec, probably providing incorrect impedance and tricking the vehicle into thinking there's a trailer attached when there isn't (which would subsequently disable parking sensors). Just a guess but this problem wasn't there before the tow pack was fitted so it's clearly related to the tow pack electrics IMHO. Still have no idea about the wrong language though!
 

·
Registered
Joined
·
46 Posts
ozsport said:
srdsol said:
"Software Update"
Seems to be the LR catch all equivalent of the IT world's "try turning it off and back on again"
On Topix there's now a bulletin related to "detachable towbar harness foul". I have no idea what's in it (no subscription) but the dealer tells me there's a bulletin so I'm guessing it's that one. No fix and no ETA from JLR :(. Based on the behaviour of the system I observed, I suspect the wiring hardness may be the wrong spec, probably providing incorrect impedance and tricking the vehicle into thinking there's a trailer attached when there isn't (which would subsequently disable parking sensors). Just a guess but this problem wasn't there before the tow pack was fitted so it's clearly related to the tow pack electrics IMHO. Still have no idea about the wrong language though!
My car has LR detachable towbar dealer fitted and no problems with parking sensors.
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #7 ·
Update from the dealer today - they've managed to get the sensors working again although the language is still wrong. They're expecting a software update this evening but have said they will handover to me tomorrow anyway. Hopefully it will be all fixed. No word yet on what they're offering as compensation, but I'll be glad to finally get my hands on it.
 

·
Registered
Joined
·
46 Posts
ozsport said:
Update from the dealer today - they've managed to get the sensors working again although the language is still wrong. They're expecting a software update this evening but have said they will handover to me tomorrow anyway. Hopefully it will be all fixed. No word yet on what they're offering as compensation, but I'll be glad to finally get my hands on it.
All the best, look forward to hearing your good news. Cheers.
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #10 ·
B48LR said:
Suspect you'll be the first to get a Learn Dutch Fast cd in your welcome pack...
Indeed... if only it had a CD player ;) hahaha
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #11 ·
Finally collected the vehicle last night and the family is very exited to finally see it in the garage. There's still a glitch with the reverse camera overlay so it will have to go back for a software update when JLR provides a fix. Appears to be an issue on all Australian fit tow electrics. Also somebody has managed to scratch it whilst it was waiting at the dealers (rear bumper - not large but straight through the paint to the plastic) so they have to repair that as well. The dealer has been very good though and we have agreed on suitable compensation for the troubles and delays. Overall the family is just glad to finally have it in the garage!
 

·
Registered
Joined
·
130 Posts
Sorry about the issues you have but hopefully all will be sorted properly soon. Hope you like it!
 

·
Registered
Joined
·
166 Posts
ozsport said:
So after many many months of waiting I was finally booked in to collect my DS this afternoon but unfortunately it was not meant to be.

SO the story goes:
After fitting the tow pack, the vehicle started displaying text on the main display in Dutch, when in reverse only. All other language was in English and resetting to English apparently didn't help. Weird but clearly a software problem. JLR recommended a software update, which was duly applied by the dealer which has:
a) not fixed the Dutch text
b) broken park assist sensors altogether
:(
So now the car's stuck in the dealer until JLR can provide a software fix that works properly. The dealer is hopeful this will be by Monday, but given the bizarre nature of the problem and the fact this is an Australian model (ie different towbar / electrics / etc) I'm not quite as optimistic. Seems highly likely related to the tow pack but AFAIK I'm the first person in country to have one fitted!

Anyway here's hoping it's sorted soon and to their credit the dealer has been very accommodating so far about the inconvenience. Will update when I have more answers :)
Hmm, I recall seeing this. Mine was in and had a software update to fix something else.. Now my reverse camera has dutch for 'check your surroundings' and whilst the car beeps for parking, all the guidelines have gone screwy and the whole behaviour of it. I think that is now issue 11 to be looked at.
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #15 ·
Who knows but they're still trying to fix mine. They've loaded several updates on so far and nothing has worked. This week they've had the JLR techs trying to dial in remotely from the UK but apparently that's not working either. Beginning to wonder if I'll ever get the vehicle back.
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #16 ·
Well finally have the vehicle back again. Camera display issue still not resolved but they tell me they've fixed the battery drain (no explanation yet but apparently they'll send it to me). It's nice to have it back again! We're only hoping we won't have any further issues.
 

·
Registered
Joined
·
428 Posts
Hi Ozsport,

Sorry to learn of the concerns you have experienced.

Could you please send me a PM with some more information to allow me to look into this further

Full Name:
Contact No:
Contact Email:
Vehicle Reg:
Land Rover Retailer:

Many thanks,
Pete
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #18 ·
Hi Ozsport,

Sorry to learn of the concerns you have experienced.

Could you please send me a PM with some more information to allow me to look into this further

Full Name:
Contact No:
Contact Email:
Vehicle Reg:
Land Rover Retailer:

Many thanks,
Pete
Hi Pete,

Happy to but I thought you only dealt with UK vehicles? (I'm in Australia)

Cheers
Ozsport
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top