Discovery Sport Forum banner
1 - 11 of 11 Posts

·
Registered
MY20 2019 D180 SE R-Dynamic
Joined
·
18 Posts
Discussion Starter · #1 ·
I've a 2019 (MY20) Discovery Sport D180 SE.
First time ever owning such a vehicle.

Struggling to understand how this Terrain Response system works.
When I press the button on the lower dash to allow me to change modes, it just flashes (I think its the icon for auto). However, once, it seemed to show lots of the modes around the rotary control, but I wasn't quick enough to do anything. Now I can't work out how to get them back.

Do I need to have the car in gear neutral, park, engine on off etc to get these modes to appear???

Just invested to know how I get the car into Snow mode, or Eco mode, or Gravel mode etc..

Any help as I can't find any guides here or online.

Thanks!
 

·
Registered
MY20 2019 D180 SE R-Dynamic
Joined
·
18 Posts
Discussion Starter · #3 ·
You press the button and turn the dial to select which mode you want. Have you read the user guide?
when I press it, only one icon flashes, nothing else appears round the control.
However, when the ignition is first switched on, before starting the engine, the icons do appear, but when I try to select them, I get a message saying Special Program not available on the screen.

Off to the dealers I suspect......
 

·
Registered
Joined
·
346 Posts
when I press it, only one icon flashes, nothing else appears round the control.
However, when the ignition is first switched on, before starting the engine, the icons do appear, but when I try to select them, I get a message saying Special Program not available on the screen.

Off to the dealers I suspect......
If it’s not doing what the user guide suggests then I’d say so, yeah.

Can you select the modes from the touchscreen? I’m pretty sure that each mode can be set from within Pivi, but if yours is a MY20 then you likely still have Incontrol Touch Pro which I’m not sure about.
 

·
Registered
MY20 2019 D180 SE R-Dynamic
Joined
·
18 Posts
Discussion Starter · #5 ·
If it’s not doing what the user guide suggests then I’d say so, yeah.

Can you select the modes from the touchscreen? I’m pretty sure that each mode can be set from within Pivi, but if yours is a MY20 then you likely still have Incontrol Touch Pro which I’m not sure about.
The Incontrol doesn’t seem to allow you to select mode, but does appear to show which one is selected. At the moment, mine just says Comfort. When I press the button on the dash to bring all the modes up, the incontrol screen says special program not available.
After googling the message it appears a dealer visit is in order.
 

·
Registered
MY20 2019 D180 SE R-Dynamic
Joined
·
18 Posts
Discussion Starter · #6 ·
Update - went to my local JLR dealership and spoke to the Sales folk and Service dept.
No one could get it working and agreed there was a problem.
Since its under warranty, car is booked in to be looked at. Mind you, 23rd May .........
 

·
Registered
MY20 2019 D180 SE R-Dynamic
Joined
·
18 Posts
Discussion Starter · #8 ·
Update. Dealer told me that car isn’t communicating with some module to sort out the 4x4. New module ordered and to be fitted in a couple of weeks. To be done under warranty.
 

·
Administrator
2016 DS HSE Auto Gas/petrol
Joined
·
748 Posts
That is good news. I find that snow mode is the only other setting I ever use and it works gggreat. I wonder if your car starts off in AWD as it should.
 

·
Registered
MY20 2019 D180 SE R-Dynamic
Joined
·
18 Posts
Discussion Starter · #10 ·
Update. Car was left back to dealers that get new module put in. Module was installed but car still not engaging 4x4. They now think it’s some IRD (??) differential transfer box?
They hope to have the car ready for me on Friday or at least have a courtesy car.
No idea what these parts are so if anyone can share any light as to whether these are common faults etc I look forward to your thoughts.
Thanks.
 

·
Registered
MY20 2019 D180 SE R-Dynamic
Joined
·
18 Posts
Discussion Starter · #11 ·
Hopefully final update.
After close to three weeks, collected the car today and the different terrain modes seem to work.
The Service Dept. told me that not only had some module been replaced, apparently some of the "can" wiring had to be replaced also. It was checked for corrosion but appeared like new. They have no idea why it failed.

Needless to say it was all repaired under warranty. They did lend me a Hybrid Lexus whilst it was in..........I did start to get a feel for electric power......
 
1 - 11 of 11 Posts
Top