Discovery Sport Forum banner
1 - 20 of 27 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
My DS has been in once already for a front end knocking noise metal to metal when you go over any sort of bumps or rutted ground. Also at speed it sorts of chatters. It's the sort of noise you get when you drive over a loose cast iron drain cover. Last time it was in they said that there was no fault found, so I went out with a senior member of the garage and he said they would need to investigate further. Its back in next week but wondered if anyone had any ideas as to what might be causing it. I've attached a link to a video I took. It's not great quality but it's just to give you an idea of the noise. Nothing is loose under the DS and the heat shields have already been fixed due to the wrong bolts being used. Appreciate any ideas to pass on to LR
 

·
Registered
Joined
·
829 Posts
Not normal surely

Could it be a loose stabilizer bar /anti-roll bar?
 

·
Registered
Joined
·
329 Posts
Mine did that until they fitted the correct bonnet stops and adjusted them correctly
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #4 ·
Lofi said:
Mine did that until they fitted the correct bonnet stops and adjusted them correctly
My DS was in the workshop all of last week dropped off Monday collected Saturday. They have replaced the shock and stabiliser on the drivers side. But not 10 minutes up the road I could hear the knocking again! Took the DS out tonight to double check but it just confirmed that anytime I go over a speed bump or hole/rut in the road you get metal on metal.
I had the bonnet stops fitted a week after I collected the DS as they were missing from the factory. If it turns out to be this it means a lot of unnecessary work has been done and 9 days my DS shouldn't have been in the dealership. The saga continues as I will be at the dealers first thing to see what they can do now.
 

·
Registered
Joined
·
8 Posts
Jpb_uk said:
Lofi said:
Mine did that until they fitted the correct bonnet stops and adjusted them correctly
My DS was in the workshop all of last week dropped off Monday collected Saturday. They have replaced the shock and stabiliser on the drivers side. But not 10 minutes up the road I could hear the knocking again! Took the DS out tonight to double check but it just confirmed that anytime I go over a speed bump or hole/rut in the road you get metal on metal.
I had the bonnet stops fitted a week after I collected the DS as they were missing from the factory. If it turns out to be this it means a lot of unnecessary work has been done and 9 days my DS shouldn't have been in the dealership. The saga continues as I will be at the dealers first thing to see what they can do now.
Just noticed mine making this type of noise, I'll have to ring the garage and see what they can do. Great post keep us updated
 

·
Registered
Joined
·
12 Posts
Mine is making this noise when it hits potholes or speed bumps with particularly aggressive inclines - seems fine if the incline is smooth and progressive but any jarring results in a knock from the front. Haven't managed to isolate to one side, sounds (and feels) like a faulty damper but will follow up on the other possible causes.

Thanks all.
 

·
Registered
Joined
·
109 Posts
Has anybody had this problem and had the car successfully fixed?

Mine goes in for its first service on Saturday (4.7K miles on the clock) and has started making this same noise described in this thread when going over speed humps. I'll report back on how it gets on at the dealership.

Other problems it has is a resonance noise from the driver's side A-Pillar trim and the seal on the reversing camera has failed so this is full of condensation.

Not a happy boy at the moment with the car :-(
 

·
Registered
Joined
·
15 Posts
Front off side knocking (metal on metal) was cured when the main dealer changed the macpherson strut. Anti roll bar rubbers were firstly changed but made no difference, surprise surprise.
Car had done a few miles short of 7k. Not impressed.
 

·
Registered
Joined
·
404 Posts
Ian H - First service already and with only 4.7k on the clock?
Do you mean first visit back to the dealer (rather than first service due at 2y or 21k miles)?
 

·
Registered
Joined
·
109 Posts
Hi Chris b, yep mines the 2.2 SD4 so the service interval is 12 months (and I keep getting reminded everytime I log in to Land Rover Remote app!)
 

·
Registered
Joined
·
109 Posts
Well, the dealer had the car on Saturday for both service and to investigate this noise from the front suspension, and (more or less as expected) agreed that there is a fault but failed to identify the cause. The car is now booked in for the whole day in two weeks time for further investigation to take place :-(
 

·
Registered
Joined
·
109 Posts
Well the car is in today for the noise from the front OS suspension - let's see if they fix it. I see there is also a bulletin on TOPIX re this issue (ltb00939 - front shock absorber noise).

Other problems to be fixed today are also rattle from the driver's side A-pillar and water getting into the rear view camera!
 

·
Registered
Joined
·
109 Posts
Well, the car was in the garage yesterday for this knocking noise and it turned out was in fact plastic 'shields' on the front suspension that had detached (on both sides), and as reported in this thread earlier the solution is to glue them back.

Of more concern though is as I mentioned in my previous post I've had a water ingress problem into the rear view camera (IMHO it looks like the seal between the lens and camera has failed). The solution (and now a modification on the Evoque housing) is to drill two 6mm holes in the housing below the camera to allow water out. Now I may be a bit hard of thinking here, but surely these holes will allow water in (as well as out). I'm just hoping the camera is in fact waterproof, and wondering how far into the Scottish winter I will get this year before salt and moisture corrode everything and the system fails!
 

·
Registered
Joined
·
12 Posts
Thanks for the update.

My noise sounds pretty metallic (metal on metal) so would be surprised if it turned out to be the plastic guards but will see.

Good luck with the rear camera, sounds like these will be a common replacement part...
 
1 - 20 of 27 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top