Discovery Sport Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter · #1 ·
I finally got my DS this week - about a month delayed.
I have a 5-seater and had ordered the detachable tow bar and a spacesaver spare wheel.
I was very positively surprised to find that the tow bar was not manually removable but moves inside the car by electric motors.
I have two buttons on the boot side wall, one to operate the tow bar and the other to switch on the lights and indicators in intervals - to check the trailer electrics.
This is a very good feature for somebody who keeps his trailer sometimes at home and sometimes at the cottage and often doesn't know in advance when to use it.

The spacesaver spare wheel (and the mud flaps and the roof rails) hasn't arrived yet but I have the repair kit anyway.
 

·
Registered
Joined
·
1,770 Posts
That little feature with the trailer light check button I am hoping to find a way of retro fitting to mine, it seems a good idea.
 

·
Registered
Joined
·
6,167 Posts
Hello IluH,

Sounds good especially since I've got it on order as well.

What does look like under the vehicle? Other members with the detachable tow hook have reported that the bodywork has been poorly cut out rather than there being a specially moulded part. Any chance of a photo?

Cheers
 

·
Registered
Joined
·
149 Posts
Discussion Starter · #4 ·
Chippy911, you are correct.
An opening has been cut in the plastics. That is actually true with many accessories - they don't make special mouldings for the different setups.
That doesn't bother me, though. You don't see the cut unless you lie down under the car.

BTW, my dealer told me not to keep the 13-to-7-pin adapter attached when deploying the tow bar. I haven't tried what would happen if I did.
 

Attachments

·
Registered
Joined
·
6,167 Posts
Thanks a lot IluH,
Thanks a lot for the picture and it actually doesn't look as bad as I was expecting it to.
I'll bear the comment about the adaptor.
 

·
Registered
Joined
·
1,770 Posts
Looks to me as if JLR only have one hole cutting template and that's large to suit the electric bar .
 

·
Registered
Joined
·
4,159 Posts
Not sure but if the adaptor is kept in place wouldn't the car think it was towing something and the reverse camera and sensors wouldn't work.
 

·
Registered
Joined
·
149 Posts
Discussion Starter · #8 ·
philn, I don't think that's the case. I believe the car will detect the actual connected trailer by the load measured in the connector. The adaptor itself wouldn't show any load.
He said you could expect a crunching sound when deploying the tow bar. :)
 

·
Registered
Joined
·
4,159 Posts
Will test tomorrow, yesterday when I unhitched a trailor my reverse camera didn't work until I switched the engine off and restarted car.
 

·
Registered
Joined
·
4,159 Posts
Just checked and if you just connect the 7/13 pin connector car doesn' t register as trailor connected.

Checked again and if I connect trailor and then disconnect with engine running although reverse camera works it doesn't show guidelines or parking sensors until I switch engine off and restart. A bit worrying as if you don't realise they are not working could lead to problems.
Would it be possible for someone else to try this to see if it is the same on your car.
 

·
Registered
Joined
·
270 Posts
philn said:
Just checked and if you just connect the 7/13 pin connector car doesn' t register as trailor connected.

Checked again and if I connect trailor and then disconnect with engine running although reverse camera works it doesn't show guidelines or parking sensors until I switch engine off and restart. A bit worrying as if you don't realise they are not working could lead to problems.
Would it be possible for someone else to try this to see if it is the same on your car.
Does your trailer have LED lights or regular lights? Most vehicles have problems detecting LED ones so it could be that.

I've not tested mine yet due to the software glitch that affects Australian spec tow packs. I thought Aus spec electrics were different but mine is the 7/13 pin connector as well I'm sure. After the software update arrives (hopefully this week) I'll do some testing and let you know.
 

·
Registered
Joined
·
4,159 Posts
Just normal lights, problem is after disconnecting trailor guidelines for reversing on camera and parking sensors don't work until engine turned off and restarted.
 

·
Registered
Joined
·
270 Posts
Ah OK. The glitch with the Australian systems is partly to do with the overlay as well (it doesn't work at all) amongst other things. Sounds like yours is not detecting the change in impedance. My sensors didn't work at all for a while so I'd say they've still got some gremlins around parking sensors / camera / tow electrics in general.
 

·
Registered
Joined
·
27 Posts

·
Registered
Joined
·
502 Posts
chrisnz,

It wasn't initially one of the towbar options. Was added around the time I ordered mine in June. So have it. It can be had in the UK with seven seats. But, you have no spare wheel, either full or skinny. Just tyre repair.

They still hack a massive chunk out of the rear of the car though to fit it.
 

·
Registered
Joined
·
27 Posts
Thanks philstix, looking back at the New Zealand MY16 order template, the option for the tyre repair system has been removed anyway. So it does not look to be an option here.

I am assuming that I will be getting a tow bar that is similar to ozsport's (I cannot find the post now but I recall seeing a photo with the tow bar removed). This looked reasonably tidy and the black rear panel should work well with the darker trim colours on the SE. However my dealer has indicated that the tow bar will be a New Zealand made unit so it will be interesting to see how it compares to photos that I have seen,
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top