Discovery Sport Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Not sure if anyone else has had this?

Seems like if I enter the car with bluetooth already on on my phone it causes a total meltdown. The system looks as if it's connected but Its just faking it, can't make receive calls, can't turn bluetooth on or off, can't pair, can't do anything. Only thing that fixes it is turn engine off, lock up, leave it a few minutes then its sorted itself out.

Interested if anyone else has had the issue (meaning a software problem) or if it's just me I'm guessing my unit is faulty.
 

·
Registered
Joined
·
31 Posts
I have the opposite problem. If I turn on Bluetooth after the engine has started it won't connect to my phone at all unless I restart the engine.
 

·
Registered
Joined
·
43 Posts
MikeLondon70 said:
Not sure if anyone else has had this?

Seems like if I enter the car with bluetooth already on on my phone it causes a total meltdown. The system looks as if it's connected but Its just faking it, can't make receive calls, can't turn bluetooth on or off, can't pair, can't do anything. Only thing that fixes it is turn engine off, lock up, leave it a few minutes then its sorted itself out.

Interested if anyone else has had the issue (meaning a software problem) or if it's just me I'm guessing my unit is faulty.
I have more or less the same problem.
My dealer has replaced the complete Entertainment system and it is still the same.
They are waited a response from JLR.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #4 ·
Ah ! Could you post up here when you get a response?
Love my car but blimey it's buggy!!!
 

·
Registered
Joined
·
1,770 Posts
Not that's is the above issue but I have found my Bluetooth buffering only happen with iPhone 4, with iOS 7.1.2 later models and newer I pads with iOS 8 are fine.
 

·
Registered
Joined
·
138 Posts
Jacko, I believe that's the normal way.
The car units usually only scan other Bluetooth devices at power-up. So you should do a manual scan or perhaps re-powering the multimedia unit would help.
 

·
Registered
Joined
·
31 Posts
IluH said:
Jacko, I believe that's the normal way.
The car units usually only scan other Bluetooth devices at power-up. So you should do a manual scan or perhaps re-powering the multimedia unit would help.
Thanks will give it a go.
 
1 - 8 of 8 Posts
Top