Discovery Sport Forum banner
261 - 280 of 308 Posts

·
Registered
Joined
·
13 Posts
Can anybody comment on the sound quality?

As the module has it's own Digital to Analogue Convertor, how is the sound quality when connecting via Android Auto or Apple Carplay?

Also can anybody confirm whether they have successfully been able to play a FLAC file via Android Auto (i.e. Android phone) using the USB?
 

·
Registered
Joined
·
32 Posts
dbwinter said:
Can anybody comment on the sound quality?

As the module has it's own Digital to Analogue Convertor, how is the sound quality when connecting via Android Auto or Apple Carplay?

Also can anybody confirm whether they have successfully been able to play a FLAC file via Android Auto (i.e. Android phone) using the USB?
To be honest, IMO the Discovery Sport Sound System isn't the top of the range sound system so the quality is not really affected. That being said, I feel that the sound is fuller and clearer than the original radio and iPod. I am using it with TuneIn and Apple Music as I am a CarPlay user.

Sorry, I cannot comment on Android Phone.

However, one point to note. I am using the wireless feature and not via the USB cable.
 

·
Registered
Joined
·
32 Posts
cortezone said:
Yes I'm afraid it does. Oh well, I'll just have to sell it and get myself a carplay dongle, if even that'll work. :)
You might want to note that your Entertainment Unit needs to have the native CarPlay feature/software before the CarPlay dongle can work. I am assuming you are referring to the CarPlay dongle in the banner ADs. The ADs are a little misleading. The dongle just enable people with CarPlay feature/software but had no wireless connectivity (these happened in the carmakers who where early adopters to Apple CarPlay that required the iPhone to be plugged in to the car's USB port to activate CarPlay. The dongle just allows the unit to be activated/communicate wireless instead of having to plug in the USB cable (lightning cable).

I hope what I am trying to say make sense to you.
 

·
Registered
Joined
·
10 Posts
dbwinter said:
Can anybody comment on the sound quality?

As the module has it's own Digital to Analogue Convertor, how is the sound quality when connecting via Android Auto or Apple Carplay?

Also can anybody confirm whether they have successfully been able to play a FLAC file via Android Auto (i.e. Android phone) using the USB?
If you mean the audio quality via IDcore or Joyauto AndroidAuto/Carplay devices then the sound quality is much better via original LR box (USB or Bluetooth). At least with Meridian system.
The AUX which is used in CarPlay/AA aftermarket interface has lower sound quality but it can read FLAC files which are useless since you can't get all FLAC advantages via AUX.
 

·
Registered
Joined
·
5 Posts
Good evening.
Do you think it is possible to connect the USB cable under the central tunnel (via an adapter) to the original socket I have in the cup holder?
Another question: has anyone fixed the microphone to the side of the original one near the rearview mirror?
Thank you
 

·
Registered
Joined
·
10 Posts
Moore said:
Good evening.
Do you think it is possible to connect the USB cable under the central tunnel (via an adapter) to the original socket I have in the cup holder?
Another question: has anyone fixed the microphone to the side of the original one near the rearview mirror?
Thank you
Well, it's certainly possible but you'll lose your USB input to the LR head unit.
Actually, I installed IDcore mic near the stock one. There is an extra mounting place
Automotive tire Gadget Gas Motor vehicle Computer hardware
 

Attachments

·
Registered
Joined
·
5 Posts
It would be the usb socket for charging (between the cup holders), not the audio one (in the armrest)... What kind of adapter should I buy?
So can you confirm that the microphone wire is long enough to pass into the passenger side pillar?
Thank you for your reply.
 

·
Registered
Joined
·
13 Posts
sbi said:
dbwinter said:
Can anybody comment on the sound quality?

As the module has it's own Digital to Analogue Convertor, how is the sound quality when connecting via Android Auto or Apple Carplay?

Also can anybody confirm whether they have successfully been able to play a FLAC file via Android Auto (i.e. Android phone) using the USB?
If you mean the audio quality via IDcore or Joyauto AndroidAuto/Carplay devices then the sound quality is much better via original LR box (USB or Bluetooth). At least with Meridian system.
The AUX which is used in CarPlay/AA aftermarket interface has lower sound quality but it can read FLAC files which are useless since you can't get all FLAC advantages via AUX.
This is an absolute deal breaker - I'm pretty surprised by this.

I currently connect my LG V30 (has one of the best mobile Sabre DACs in the world inside) via AUX and the sound quality is very good. The 380w Meridian is pretty neutral, perhaps only lacking in sub-bass.

I was hoping to connect my LG V30 via USB to the IDcore/Joyauto using Android Auto and have proper satellite navigation via Google and play FLAC music files via the Neutron application.

Could you confirm that you have played a good quality FLAC music file and it really sounds a lot worse?

They must have really messed up the Digital to Analogue conversion if this is the case.
 

·
Registered
Joined
·
10 Posts
Hi dbwinter.

I tried to play good quality FLAC via usb and the sound was worse than the same track from Google Play Music via BT on Pixel 2. It's not that crisp, quieter, and lacking surround effect or something.
I also tried to play the same track via AUX on my Pixel 2 and the quality was worse than via BT as well. Maybe it's because IDcore device is wired in.. Need to disconnect it and check once again.
But this will require a lot of manual work on disassembling and putting everything back:)
Overall if you use AA and Carplay in Wireless mode all the phone calls, music playing will go via BT automatically.
Unfortunately, it's not my case since I'm the lucky one with a Pixel 2 updated to Android 11 where AA is completely messed.
But tried Carplay on my friend's iPhone and was impressed with how easy and fast the wireless connection is working.
 

·
Registered
Joined
·
2 Posts
lionshead said:
Well the OEM rear camera works!!

Cable run from the units 'REAR C" wire to one of the reversing lights. Was a little easier than I expected - just took time hiding the cable through the car. Thanks to all those that posted comments.
Hi I have been reading the thread and I happen to have the same issue with the rear view camera. Do you happen to have any pics of how to wire to the reversing lights? Thanks
 

·
Registered
Joined
·
2 Posts
discomickey said:
OK...so after quite a bit of correspondence with the AliExpress store, I seem to have resolved both of the major issues.

Firstly, the support from the AliExpress store has been truly excellent. Very responsive and helpful. Some messages lost in translation but with a few follow up questions and hand drawn diagrams we got there in the end. If you would like to purchase from them then here is the link to the item (I have absolutley no affliation or relationship with the store but feel that they deserve further sales for the support they provided):

https://a.aliexpress.com/_dTRQWoY

So for the issue with the sound coming in and out. This appears to be an issue for older DSs (2016 and earlier) - you do need to cut (or in my case disconnect two cables from the white connector that goes into the box). See the photo attached. The english translation is not so clear but what you need to do is place the connector as shown with the yellow cable on the left.

Then count 5 pins to the right (where yellow is #1). Then remove the pins on both the top and bottom rows of the connector. I felt it was better to disconnect from the connector rather than cut the cables so that I could reconnect if any issues. I think shrink wrapped the two cables to prevent shorting etc

The second issue was in relation to the rear reverse camera not coming on when putting the DS in reverse. Again this seems to be specific to DSs from 2016 and earlier. It works in the original LR interface but not the CarPlay interface. As previously covered, you do need to connect a wire from the orange reverse camera trigger cable on the aftermarket wiring harness to one of the reversing lights.

I actually took some insipration from another post on the forum which talked about connecting a trickle charger to the towing electrics connector block in the boot.

https://www.discosportforums.co.uk/viewtopic.php?f=8&t=4342&hilit=Ctek+fitting&start=10

Rather than remove all the tailgate trim and connect to a rear reversing light, I attached a cable to the yellow and brown cable on the towing electrics connector block. The biggest pain was routing the cable under the door trims / carpets etc from front to back. Managed it in the end and now the sound and reversing camera is working fine in CarPlay mode.

Thanks to all those that have been before me to help diagnose the issues. If anyone wants further help then please DM me or reply here.
HI, I see that you did the same thing with the rear camera not working. Do you have any pics of how you did the connection? or what the cables are? I dont know much about electrics and the seller is just telling me to change the 1-8 pins. Thanks
 

·
Registered
Joined
·
7 Posts
Hi there - what is the year of manufacture of your vehicle? Depending on your year, it may be that playing with the dip switches will fix your issue.

Otherwise you need to connect a cable (e.g. I used a length of alarm cable) from the rear of your DS (you have to connect to one of the pins in the towing electric block on the inside rear bumper of your DS near the car jack etc) to a specific cable near where the aftermarket CarPlay box is situated in the dash).

It is a bit of a pain but quite safe to do (if you read my instructions then hopefully clear?)
 

·
Registered
Joined
·
12 Posts
I bit the bullet and bought one from AliExpress for Christmas, on sale for $270. I did the install on my 2017 Disco Sport SE today. It took me almost 6 hours, but the Topix documents mentioned earlier helped a ton...followed to the letter...as well as pics and guidance in this thread. Realized I didn't need to remove my touch screen as everything connects to the head unit which is behind AC controls. I took the time to run the Mic to the overhead console using the blank mic area above the SOS button...worked out perfectly. I connected the audio cables to each other in the wiring loom and then the blank audio adapter that came with kit in the Aux in center console. Dip switches I turned all off except 1 and 8...factory rear camera works perfectly. I didn't have to cut into any wiring...all plug and play. Took it for a drive tonight and it really is AWESOME. Waze works great, Sirius XM App as well. Siri reads my texts to me and takes commands fine. Wish I would have done this a year ago....very pleased so far!
 

·
Registered
Joined
·
10 Posts
Rmutchler said:
I bit the bullet and bought one from AliExpress for Christmas, on sale for $270. I did the install on my 2017 Disco Sport SE today. It took me almost 6 hours, but the Topix documents mentioned earlier helped a ton...followed to the letter...as well as pics and guidance in this thread. Realized I didn't need to remove my touch screen as everything connects to the head unit which is behind AC controls. I took the time to run the Mic to the overhead console using the blank mic area above the SOS button...worked out perfectly. I connected the audio cables to each other in the wiring loom and then the blank audio adapter that came with kit in the Aux in center console. Dip switches I turned all off except 1 and 8...factory rear camera works perfectly. I didn't have to cut into any wiring...all plug and play. Took it for a drive tonight and it really is AWESOME. Waze works great, Sirius XM App as well. Siri reads my texts to me and takes commands fine. Wish I would have done this a year ago....very pleased so far!
Lucky iPhone user:)))
Google killed completely wireless Android Auto with the latest Android version:(
 

·
Registered
Joined
·
10 Posts
Moore said:
sbi said:
Lucky iPhone user:)))
Google killed completely wireless Android Auto with the latest Android version:(
What problems have you encountered with Android Auto?
Have you already updated the new firmware (https://unique-ad.co.uk/software-updates/)?
AA in my case is a complete disaster. Wireless mode is not working, therefore music output is possible via AUX only, which is absolutely a huge disadvantage for the Meridian system. Night mode is not working as well (tried to enable it via Dev options already), strangely enough on my wife's same Pixel 2 model it's working correctly. Seems like something wrong with my Google account since night mode is not working on the brand new Pixel 3 XL as well:)
And thank you for the hint regarding the new FW!:) Will ask the seller to give it to me. Didn't check for some time:)

Btw noticed another strange behavior, when it was quite cold in our region, especially below -10 C, when I start the car there is no sign of life on the multimedia screen. And after I drive for some time, stop the car and let the multimedia go to sleep the screen is back again.
 

·
Registered
Joined
·
10 Posts
Moore said:
sbi said:
Lucky iPhone user:)))
Google killed completely wireless Android Auto with the latest Android version:(
What problems have you encountered with Android Auto?
Have you already updated the new firmware (https://unique-ad.co.uk/software-updates/)?
Well, tried to contact the seller on aliexpress who sold me that device, the one that was mentioned here once with good reviews.. looks like he turned "Dumb and Dumber" mode, telling me that update is not needed, that that's a phone issue etc.
Anyone who ordered a device from unique-ad.co.uk could you please share the latest update?
 
261 - 280 of 308 Posts
Top