Discovery Sport Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
OK, so the FL2 I had for a while made what I'll call an "electrical tone" for about three minutes after driving, switching off and locking.

The DS is still going about 20 minutes after I got home.

Any ideas how long this goes on for?

The missus is now taking the piss - she got our new baby off to sleep perfectly this evening; whereas my new baby is still whining...
 

·
Registered
Joined
·
81 Posts
Mine does this until I lock it
 

·
Registered
Joined
·
179 Posts
Radds said:
The missus is now taking the piss - she got our new baby off to sleep perfectly this evening; whereas my new baby is still whining...
:lol: :lol: :lol:
 

·
Registered
Joined
·
381 Posts
I noticed this on my weekend loaner and sometimes my XF does it, I had a Outlander before the XF with the 2.2 engine and that did it also, sounds a bit like a capacitor discharging.
 

·
Registered
Joined
·
19 Posts
Mine does it and so did my FL2. My FL2 always seemed to do it after the lights had been on for a while and I notice it on the DS after driving at night. I always assumed it was related to the Xenon lights and maybe a discharging sound. I can't confirm how long it goes on for but on occasion maybe a few minutes.
 

·
Registered
Joined
·
6,167 Posts
I have the same on my FL2. It's not every time I switch off the engine, the duration and sound can vary. Neither I nor the dealer know what causes it but everything works as it should. No Xenon's and it doesn't sound like a discharging noise.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #8 ·
Thanks for the responses guys. It stopped eventually so I switched off the outside light and tiptoed quietly away...
 

·
Registered
Joined
·
109 Posts
If it's a high pitch from the engine bay it's the throttle resetting and should stop after 30 seconds. This was a popular topic on the FL2 forum.
 
1 - 9 of 9 Posts
Top