Discovery Sport Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Has anyone else experienced electrical issues which result in a complete battery drain? On two occasions in our 4 weeks of ownership we have gone out to find the car dead. Dealer has replaced a faulty controller once, but the problem has returned! LR Assistance have got it started again, but it's back to the dealer again...

It's also been back to the dealer because the heater wasn't working, diagnosed as a software issue. Disappointing this wasn't picked up when it was with them the week before or before I took delivery.
 

·
Registered
Joined
·
562 Posts
Sorry to here. Dealer PDI's are just a wash these days......I hope you get it resolved. Are you always going back to a flat battery each morning? Just to say, motion sensor security lights used to operate on same freq as key fob on my RR and the car kept energising itself thinking it was being unlocked. Try parking in a different place?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the suggestion Triple7. We don't use the car every day and the fault is intermittent. Once after standing for 2 days, more recently after 3 days.
 

·
Registered
Joined
·
4,159 Posts
My wife bought a new clio and 2 weeks after buying it she returned after 4 hours to find it completely dead with nothing left on. The dealer checked it over but found nothing wrong. That was 2 years ago and it hasn't happened again - odd.
 

·
Registered
Joined
·
19 Posts
I did a 160 mile round trip Sunday then locked up the car outside my house. In the morning I opened the car (the boot refused to auto-open) and there was a warning that the "Battery was very low". Looks like I caught it in time, but nothing had been left on and it didn't make sense how the battery could be run down. It's going in to be looked at next Tuesday along with the fact that also on Monday some of the heat shield around the exhaust (middle of car) fell off and was dragging on the road.
 

·
Registered
Joined
·
829 Posts
Within weeks of getting my RR Evoque, the battery drained itself a few times. Also quite randomly and even after a long drive. Several visits to dealer revealed that the battery comes with a "smart" computer which decides when to charge the battery and to keep track of voltage. Turns out that if this device resets itself while the battery is 50% charge, "it" thinks to be fully charged and allows the battery to drain. This device also does not detect when you use the battery with the engine off (to inflate a boat or...)

Dealer replaced battery computer device and reset the software. No issues since...
 

·
Registered
Joined
·
1,770 Posts
Mine seem to be the same, came to it today opened the boot ok, it then refused to shut, and car would not start, battery dead, currently on charge.
 

·
Registered
Joined
·
329 Posts
This is terrible news. Seems like another part that isn't up to the job. Batteries really hate being fully discharged as do the electrics in cars. I'm getting pretty concerned about the experience once our car finally arrives.
 

·
Registered
Joined
·
1,770 Posts
It's the random nature that worries me , some cars are ok in one area and not in another.
 

·
Registered
Joined
·
329 Posts
The squeaks, rattles, air con not cold, funny radio, odd iPod behaviour I can deal with but I absolutely cannot have a car that needs to sit on a battery conditioner to ensure it is ready to take the kids to school and my Mrs to work. I have a car that sits on a battery conditioner but that's because it's only used at the weekend and is 15 years old. The idea of doing the same with the daily driver is unimaginable.

Please keep us updated on the resolution.
 

·
Registered
Joined
·
329 Posts
Did this get resolved?
 

·
Registered
Joined
·
1,770 Posts
Dealer told me to let it go flat and ring LR assist as they would change the battery if that's what was wrong, seems a cop out to me, there is a very good piece on the D3/4 forum about checking for battery drain, I feel like printing it off and giving it to the dealer.
 

·
Registered
Joined
·
329 Posts
Deffo a cope out, treat the symptom not the cause. Usual way to check for drain is to put a meter inline and remove fuses one by one. Time consuming and not something you should be doing in the first month!
 

·
Registered
Joined
·
829 Posts
Post from Chippy on new Bosch electronics (start/stop topic) also explained EBC, Electronic Battery Charging (from memory). That exact unit that monitored my RR Evoque battery was faulty and drained my battery regularly. I also got a new battery which was wasted again as the battery itself is rarely the real cause...
 

·
Registered
Joined
·
16 Posts
Hi, only things we have seen in 4 weeks of ownership is sometimes it wont read the Navigation SD card, and all of the lane assist stuff all throwing alerts on the dashboard to say nothings working, caution etc....

The response from the dealer was to "turn it of and on again" - and sadly.......... it worked :-(
 
G

·
I think that with all the new electronics on board the cars are becoming more computer like. Lets hope its not microsoft which lets the users find all the faults....... regular software updates are now part of vehicle ownership, just wait for viruses particularly as we will download apps from the internet!!
 

·
Registered
Joined
·
270 Posts
Mine did this today. Didn't get driven yesterday and was completely dead when my wife went to drive it. Roadside assist came and jump started it and I drove it around for a bit. It was reading over 12 volts on my multimeter by the time I got back but still had the red warning triangle on the dash. Might need a reset as mentioned earlier. It's currently on charge so I'll see what it's like tomorrow...
 

·
Registered
Joined
·
829 Posts
Will be a software management issue. Such a new battery should never drop below 12v, even if not used for 3 weeks
 

·
Registered
Joined
·
1,770 Posts
Mine required a new battery, one of the cell was dead, yet is got out of the factory and the dealers missed it (twice) in the end LR assist came with a m/c and diagnosed it in seconds with some piece of kit.
It has been ok ever since.
 
1 - 20 of 28 Posts
Top